گیاهی ترین گیاهی ترین AnzanDigital فروشگاه
خانه / کیوت / ابزار های توسعه ی آندروید توسط QT
devicesjpg

ابزار های توسعه ی آندروید توسط QT

devicesjpg

شروع کا با QT برای توسعه آندروید

نیازمندی ها:

برای استفاده از QT for Android به ابزار های زیر نیاز دارید:

  1. ابزار Android SDK (نسخه لینوکس android-sdk_r24.3.3-linux | نسخه ویندوز | نسخه مک )
  2. Android NDK (نسخه لینوکس 32 بیت و 64 بیت | نسخه ویندوز 32 بیت و 64 بیت | نسخه مک 64)
  3. Apache Ant v1.8 (سایت سازنده) یا بالاتر
  4. Jave SE Dev Kit نسخه ی 6 یا بالاتر. یا استفاده از OpenJDK در لینوکس
  5. بر روی ویندوز نیازمند نصب ابزار های دیگری نیز است:

راهنداز Android Debug Bridge بر روی پلتفرم ویندوز برای فعال سازی خطا یابی از طریق USB، در صورتی که راهنداز پیش فرض بر روی ویندوز اجازه ی خطا یابی از طریق USB را فراهم نمی کند. برای اطلاعات بیشتر وارد شوید.

بعد نصب راهنداز، چندین دستور ساده ی  adb commands را اجرا کرده و از پاسخ وسیله ی خود مطمئن شوید.


بعد از نصب این ابزار ها، Android SDK را برای دسترسی به API و بسته های ابزاری لازم برای توسعه به روز کنید. شما می توانید SDK را توسط ابزار android که به همراه بسته های ابزاری SDK هستند، به روز کنید. در لینوکس-ابونتو دستورات زیر Android SDK Manager را راهندازی می کند و شما را قادر می ساز بسته هایی مورد نیاز را نصب کنید.

./android update sdk

توجه: اگر از سیستم 64 بیت استفاده میکنید، بایستی پیش نیاز های زیر را برای اجرای فایل 32 بیت مانند adb نصب کرده که کامپایلر QT را قادر می ساز وسیله ی شما را شناسایی کند:

sudo apt-get install libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386

برای اجرای شبیه ساز، پیش نیاز های زیر ضروری اند:

sudo apt-get install libsdl1.2debian:i386

نصب QT برای آندروید :

فایل نصبی QT5 برای پلتفرم های مختلف در صفحه ی دانلود قابل دریافت است.

کانال تلگرام بیر رباتیک

درباره Ahrovani Hadi

مشاهده بیشتر

arducopter simulation

شبیه سازی اتوپایلوت و تشخیص کد های Aruco

ویدئوی پیوست شده شبیه سازی اتوپایلوت ardupilot با شبیه ساز gazebo را نشان میدهد. این …

دیدگاه بگذارید

اولین نفری باشید که دیدگاه میگذارد

با خبر سازی از
avatar

wpDiscuz